use strict;
my $str = 'feat: NSPS2-1277 A valid commit message
chore:NSPS2-1277 A valid commit message
fix: NSPS2-1277 A valid commit message
security: NSPS2-1277 A valid commit message
wip: NSPS2-1277 A valid commit message';
my $regex = qr/^(feat|chore|fix|security|wip):[ ]?[A-Z0-9]+-[0-9]+.{3,}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}