$re = '/(?<=\d)(?=\D)/m';
$str = 'Prdct_1Prdct_2Prdct_3Prdct_4Prdct_5Prdct_6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);