using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{(?:[^{}]|(?R))*\}";
string input = @"{
""title"": ""This is a a test }"",
""date"": ""2017-11-16T20:47:16+00:00""
}
This is a a test }
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}