package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{(?:[^{}]|(?R))*\}`)
var str = `{
"title": "This is a a test }",
"date": "2017-11-16T20:47:16+00:00"
}
This is a a test }
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}