const regex = /^(?:[\t ]*(?:\r?\n|\r))+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[\\t ]*(?:\\r?\\n|\\r))+', 'gm')
const str = `TITLE ---
=========
Ergo Proxy Sinus Putrid A.D.2049
§ - Chapter 01
Textum Receptus
Holy [link](https://www.unicode.org/index.html)
Image 01-
..
Image 09
§§°ç^?
§ - Chapter 2 %&&&
End.
Loigismo Amonitus Heracleion
Poltrer Hegheist Lotrar Ultreum
Unicus Scribus """!€*ù7n
Olk/6
//n
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);