# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[\t ]*(?:\r?\n|\r))+"
test_str = ("TITLE ---\n"
"=========\n\n\n"
"Ergo Proxy Sinus Putrid A.D.2049\n"
"§ - Chapter 01\n\n\n\n"
"Textum Receptus \n"
"Holy [link](https://www.unicode.org/index.html)\n\n"
"Image 01-\n"
"..\n"
"Image 09\n\n"
"§§°ç^?\n"
" § - Chapter 2 %&&&\n\n"
"End.\n"
"Loigismo Amonitus Heracleion\n"
"Poltrer Hegheist Lotrar Ultreum\n\n\n\n\n"
"Unicus Scribus \"\"\"!€*ù7n\n"
"Olk/6\n\n"
"//n\n\n\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.