$re = '/^[\s]*(?!static)[\s]*GS::(|Data|Event|Error|Fatal|Info|Trace|Warning)LogLine[\s]*/m';
$str = '	static	     GS::DataLogLine log5 ("File sizes:                total: %, meta data partition: %, user data partition: %");';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);