re = /\b([^:\n]*):\s*B/m
str = 'John SMith: A
Pedro Smith: B
Jonathan B: A
John B: B
Luis Diaz: A
Scarlet Diaz: B'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end