#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((0?[x|X])|#)?[0-9,A-F,a-f]{8}|#([0-9,A-F,a-f]{6})"
Local $sString = "werwerwer 0x00000258qqdwef 4123r31ed0x0xxx00x0x00000001wefv sdfgsdgfdsfghsdfg#FA1EBFfwefweberF"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")