const regex = /<h2 class="text-center">14 января 2019[\s\S]*?<tr class="bordergrey">[\s\S]*?"Время" class="text\-center">(.*?)<\/td>[\s\S]*?"Название предмета">(.*?)<\/td>[\s\S]*?"Кабинет" class="text-center">(.*?)<\/td>[\s\S]*?"Преподаватель" class="text-center">(.*?)<\/td>[\s\S]*?<\/tr>[\s\S]*?<\/div>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<h2 class="text-center">14 января 2019[\\s\\S]*?<tr class="bordergrey">[\\s\\S]*?"Время" class="text\\-center">(.*?)<\\\/td>[\\s\\S]*?"Название предмета">(.*?)<\\\/td>[\\s\\S]*?"Кабинет" class="text-center">(.*?)<\\\/td>[\\s\\S]*?"Преподаватель" class="text-center">(.*?)<\\\/td>[\\s\\S]*?<\\\/tr>[\\s\\S]*?<\\\/div>', 'gm')
const str = `<div class="raspcontent m5" name="raspcontent">
<h2 class="text-center">09.02.04 Информационные системы (по отраслям)</h2>
<div class="panel panel-default edu_panel1c" id="current">
<div class="panel-heading edu_today">
<h2 class="text-center">14 января 2019, понедельник</h2>
</div>
<div class="panel-body" style="overflow:auto">
<table id="mobile-friendly" class="table table-bordered rasp">
<thead>
<tr>
<th style="width: 20px;" class="text-center">Номер урока</th>
<th class="text-center" style="width: 110px;">Время</th>
<th style="width: 350px;" class="text-center">Название предмета</th>
<th class="text-center">Кабинет</th>
<th class="text-center">Преподаватель</th>
</tr>
</thead>
<tbody>
<tr class="bordergrey"><td data-title="Номер урока" class="text-center" rowspan="1">1</td><td data-title="Время" class="text-center">08:00 - 08:45</td>
<td data-title="Название предмета">Компьютерное моделирование </td>
<td data-title="Кабинет" class="text-center">У-29</td>
<td data-title="Преподаватель" class="text-center">Кокшаров Сергей Владимирович</td>
</tr>
<tr class="borderwhite"><td data-title="Номер урока" class="text-center" rowspan="1">2</td><td data-title="Время" class="text-center">08:50 - 09:35</td>
<td data-title="Название предмета">Компьютерное моделирование </td>
<td data-title="Кабинет" class="text-center">У-29</td>
<td data-title="Преподаватель" class="text-center">Кокшаров Сергей Владимирович</td>
</tr>
<tr class="bordergrey"><td data-title="Номер урока" class="text-center" rowspan="1">3</td><td data-title="Время" class="text-center">09:45 - 10:30</td>
<td data-title="Название предмета">Безопасность и управление доступом </td>
<td data-title="Кабинет" class="text-center">У-310</td>
<td data-title="Преподаватель" class="text-center">Желонкина Марина Валерьевна</td>
</tr>
<tr class="borderwhite"><td data-title="Номер урока" class="text-center" rowspan="1">4</td><td data-title="Время" class="text-center">10:35 - 11:20</td>
<td data-title="Название предмета">Безопасность и управление доступом </td>
<td data-title="Кабинет" class="text-center">У-310</td>
<td data-title="Преподаватель" class="text-center">Желонкина Марина Валерьевна</td>
</tr>
<tr class="bordergrey"><td data-title="Номер урока" class="text-center" rowspan="1">5</td><td data-title="Время" class="text-center">11:50 - 12:35</td>
<td data-title="Название предмета">Безопасность и управление доступом </td>
<td data-title="Кабинет" class="text-center">У-310</td>
<td data-title="Преподаватель" class="text-center">Желонкина Марина Валерьевна</td>
</tr>
<tr class="borderwhite"><td data-title="Номер урока" class="text-center" rowspan="1">6</td><td data-title="Время" class="text-center">12:40 - 13:25</td>
<td data-title="Название предмета">Безопасность и управление доступом </td>
<td data-title="Кабинет" class="text-center">У-310</td>
<td data-title="Преподаватель" class="text-center">Желонкина Марина Валерьевна</td>
</tr> <tbody>
</table>
</div>
</div>
<div class="panel panel-default edu_panel1c" id="current">
<div class="panel-heading edu_today">
<h2 class="text-center">15 января 2019, вторник</h2>
</div>
<div class="panel-body" style="overflow:auto">
<table id="mobile-friendly" class="table table-bordered rasp">
<thead>
<tr>
<th style="width: 20px;" class="text-center">Номер урока</th>
<th class="text-center" style="width: 110px;">Время</th>
<th style="width: 350px;" class="text-center">Название предмета</th>
<th class="text-center">Кабинет</th>
<th class="text-center">Преподаватель</th>
</tr>
</thead>
<tbody>
<tr class="bordergrey"><td data-title="Номер урока" class="text-center" rowspan="1">1</td><td data-title="Время" class="text-center">08:20 - 09:05</td>
<td data-title="Название предмета">Интеллектуальные системы и технологии </td>
<td data-title="Кабинет" class="text-center">У-29</td>
<td data-title="Преподаватель" class="text-center">Кокшаров Сергей Владимирович</td>
</tr>
<tr class="borderwhite"><td data-title="Номер урока" class="text-center" rowspan="1">2</td><td data-title="Время" class="text-center">09:10 - 09:55</td>
<td data-title="Название предмета">Интеллектуальные системы и технологии </td>
<td data-title="Кабинет" class="text-center">У-29</td>
<td data-title="Преподаватель" class="text-center">Кокшаров Сергей Владимирович</td>
</tr>
<tr class="bordergrey"><td data-title="Номер урока" class="text-center" rowspan="1">3</td><td data-title="Время" class="text-center">10:05 - 10:50</td>
<td data-title="Название предмета">Современные программные продукты в области экономики и управления </td>
<td data-title="Кабинет" class="text-center">У-302</td>
<td data-title="Преподаватель" class="text-center">Ярыгина Светлана Николаевна</td>
</tr>
<tr class="borderwhite"><td data-title="Номер урока" class="text-center" rowspan="1">4</td><td data-title="Время" class="text-center">10:55 - 11:40</td>
<td data-title="Название предмета">Современные программные продукты в области экономики и управления </td>
<td data-title="Кабинет" class="text-center">У-302</td>
<td data-title="Преподаватель" class="text-center">Ярыгина Светлана Николаевна</td>
</tr>
<tr class="bordergrey"><td data-title="Номер урока" class="text-center" rowspan="1">5</td><td data-title="Время" class="text-center">12:10 - 12:55</td>
<td data-title="Название предмета">Иностранный язык </td>
<td data-title="Кабинет" class="text-center">У-330</td>
<td data-title="Преподаватель" class="text-center">Мукашева Мария Сергеевна</td>
</tr>
<tr class="borderwhite"><td data-title="Номер урока" class="text-center" rowspan="1">6</td><td data-title="Время" class="text-center">13:00 - 13:45</td>
<td data-title="Название предмета">Иностранный язык </td>
<td data-title="Кабинет" class="text-center">У-330</td>
<td data-title="Преподаватель" class="text-center">Мукашева Мария Сергеевна</td>
</tr> <tbody>
</table>
</div>
</div>
<div class="panel panel-default edu_panel1c" id="current">
<div class="panel-heading edu_today">
<h2 class="text-center">16 января 2019, среда</h2>
</div>
<div class="panel-body" style="overflow:auto">
<table id="mobile-friendly" class="table table-bordered rasp">
<thead>
<tr>
<th style="width: 20px;" class="text-center">Номер урока</th>
<th class="text-center" style="width: 110px;">Время</th>
<th style="width: 350px;" class="text-center">Название предмета</th>
<th class="text-center">Кабинет</th>
<th class="text-center">Преподаватель</th>
</tr>
</thead>
<tbody>
<tr class="bordergrey"><td data-title="Номер урока" class="text-center" rowspan="1">1</td><td data-title="Время" class="text-center">08:00 - 08:45</td>
<td data-title="Название предмета">Безопасность и управление доступом </td>
<td data-title="Кабинет" class="text-center">У-310</td>
<td data-title="Преподаватель" class="text-center">Желонкина Марина Валерьевна</td>
</tr>
<tr class="borderwhite"><td data-title="Номер урока" class="text-center" rowspan="1">2</td><td data-title="Время" class="text-center">08:50 - 09:35</td>
<td data-title="Название предмета">Безопасность и управление доступом </td>
<td data-title="Кабинет" class="text-center">У-310</td>
<td data-title="Преподаватель" class="text-center">Желонкина Марина Валерьевна</td>
</tr>
<tr class="bordergrey"><td data-title="Номер урока" class="text-center" rowspan="1">3</td><td data-title="Время" class="text-center">09:45 - 10:30</td>
<td data-title="Название предмета">Безопасность и управление доступом </td>
<td data-title="Кабинет" class="text-center">У-310</td>
<td data-title="Преподаватель" class="text-center">Желонкина Марина Валерьевна</td>
</tr>
<tr class="borderwhite"><td data-title="Номер урока" class="text-center" rowspan="1">4</td><td data-title="Время" class="text-center">10:35 - 11:20</td>
<td data-title="Название предмета">Безопасность и управление доступом </td>
<td data-title="Кабинет" class="text-center">У-310</td>
<td data-title="Преподаватель" class="text-center">Желонкина Марина Валерьевна</td>
</tr>
<tr class="bordergrey"><td data-title="Номер урока" class="text-center" rowspan="1">5</td><td data-title="Время" class="text-center">11:50 - 12:35</td>
<td data-title="Название предмета">Компьютерное моделирование </td>
<td data-title="Кабинет" class="text-center">У-29</td>
<td data-title="Преподаватель" class="text-center">Кокшаров Сергей Владимирович</td>
</tr>
<tr class="borderwhite"><td data-title="Номер урока" class="text-center" rowspan="1">6</td><td data-title="Время" class="text-center">12:40 - 13:25</td>
<td data-title="Название предмета">Компьютерное моделирование </td>
<td data-title="Кабинет" class="text-center">У-29</td>
<td data-title="Преподаватель" class="text-center">Кокшаров Сергей Владимирович</td>
</tr> <tbody>
</table>
</div>
</div>
<div class="panel panel-default edu_panel1c" id="current">
<div class="panel-heading edu_today">
<h2 class="text-center">17 января 2019, четверг</h2>
</div>
<div class="panel-body" style="overflow:auto">
<table id="mobile-friendly" class="table table-bordered rasp">
<thead>
<tr>
<th style="width: 20px;" class="text-center">Номер урока</th>
<th class="text-center" style="width: 110px;">Время</th>
<th style="width: 350px;" class="text-center">Название предмета</th>
<th class="text-center">Кабинет</th>
<th class="text-center">Преподаватель</th>
</tr>
</thead>
<tbody>
<tr class="bordergrey"><td data-title="Номер урока" class="text-center" rowspan="1">1</td><td data-title="Время" class="text-center">08:00 - 08:45</td>
<td data-title="Название предмета">Современные программные продукты в области экономики и управления </td>
<td data-title="Кабинет" class="text-center">У-302</td>
<td data-title="Преподаватель" class="text-center">Ярыгина Светлана Николаевна</td>
</tr>
<tr class="borderwhite"><td data-title="Номер урока" class="text-center" rowspan="1">2</td><td data-title="Время" class="text-center">08:50 - 09:35</td>
<td data-title="Название предмета">Современные программные продукты в области экономики и управления </td>
<td data-title="Кабинет" class="text-center">У-302</td>
<td data-title="Преподаватель" class="text-center">Ярыгина Светлана Николаевна</td>
</tr>
<tr class="bordergrey"><td data-title="Номер урока" class="text-center" rowspan="1">3</td><td data-title="Время" class="text-center">09:45 - 10:30</td>
<td data-title="Название предмета">Современные программные продукты в области экономики и управления </td>
<td data-title="Кабинет" class="text-center">У-302</td>
<td data-title="Преподаватель" class="text-center">Ярыгина Светлана Николаевна</td>
</tr>
<tr class="borderwhite"><td data-title="Номер урока" class="text-center" rowspan="1">4</td><td data-title="Время" class="text-center">10:35 - 11:20</td>
<td data-title="Название предмета">Современные программные продукты в области экономики и управления </td>
<td data-title="Кабинет" class="text-center">У-302</td>
<td data-title="Преподаватель" class="text-center">Ярыгина Светлана Николаевна</td>
</tr> <tbody>
</table>
</div>
</div>
<div class="panel panel-default edu_panel1c" id="current">
<div class="panel-heading edu_today">
<h2 class="text-center">18 января 2019, пятница</h2>
</div>
<div class="panel-body" style="overflow:auto">
<table id="mobile-friendly" class="table table-bordered rasp">
<thead>
<tr>
<th style="width: 20px;" class="text-center">Номер урока</th>
<th class="text-center" style="width: 110px;">Время</th>
<th style="width: 350px;" class="text-center">Название предмета</th>
<th class="text-center">Кабинет</th>
<th class="text-center">Преподаватель</th>
</tr>
</thead>
<tbody>
<tr class="bordergrey"><td data-title="Номер урока" class="text-center" rowspan="1">1</td><td data-title="Время" class="text-center">08:00 - 08:45</td>
<td data-title="Название предмета">Компьютерное моделирование </td>
<td data-title="Кабинет" class="text-center">У-29</td>
<td data-title="Преподаватель" class="text-center">Кокшаров Сергей Владимирович</td>
</tr>
<tr class="borderwhite"><td data-title="Номер урока" class="text-center" rowspan="1">2</td><td data-title="Время" class="text-center">08:50 - 09:35</td>
<td data-title="Название предмета">Компьютерное моделирование </td>
<td data-title="Кабинет" class="text-center">У-29</td>
<td data-title="Преподаватель" class="text-center">Кокшаров Сергей Владимирович</td>
</tr>
<tr class="bordergrey"><td data-title="Номер урока" class="text-center" rowspan="1">3</td><td data-title="Время" class="text-center">09:45 - 10:30</td>
<td data-title="Название предмета">Безопасность и управление доступом </td>
<td data-title="Кабинет" class="text-center">У-310</td>
<td data-title="Преподаватель" class="text-center">Желонкина Марина Валерьевна</td>
</tr>
<tr class="borderwhite"><td data-title="Номер урока" class="text-center" rowspan="1">4</td><td data-title="Время" class="text-center">10:35 - 11:20</td>
<td data-title="Название предмета">Безопасность и управление доступом </td>
<td data-title="Кабинет" class="text-center">У-310</td>
<td data-title="Преподаватель" class="text-center">Желонкина Марина Валерьевна</td>
</tr>
<tr class="bordergrey"><td data-title="Номер урока" class="text-center" rowspan="1">5</td><td data-title="Время" class="text-center">11:50 - 12:35</td>
<td data-title="Название предмета">Безопасность и управление доступом </td>
<td data-title="Кабинет" class="text-center">У-310</td>
<td data-title="Преподаватель" class="text-center">Желонкина Марина Валерьевна</td>
</tr>
<tr class="borderwhite"><td data-title="Номер урока" class="text-center" rowspan="1">6</td><td data-title="Время" class="text-center">12:40 - 13:25</td>
<td data-title="Название предмета">Безопасность и управление доступом </td>
<td data-title="Кабинет" class="text-center">У-310</td>
<td data-title="Преподаватель" class="text-center">Желонкина Марина Валерьевна</td>
</tr>
<tr class="bordergrey"><td data-title="Номер урока" class="text-center" rowspan="1">7</td><td data-title="Время" class="text-center">13:30 - 14:15</td>
<td data-title="Название предмета">Физическая культура </td>
<td data-title="Кабинет" class="text-center">У-107</td>
<td data-title="Преподаватель" class="text-center">Беженарь Василий Дмитриевич</td>
</tr>
<tr class="borderwhite"><td data-title="Номер урока" class="text-center" rowspan="1">8</td><td data-title="Время" class="text-center">14:20 - 15:05</td>
<td data-title="Название предмета">Физическая культура </td>
<td data-title="Кабинет" class="text-center">У-107</td>
<td data-title="Преподаватель" class="text-center">Беженарь Василий Дмитриевич</td>
</tr> <tbody>
</table>
</div>
</div>
<div class="panel panel-default edu_panel1c" id="current">
<div class="panel-heading edu_today">
<h2 class="text-center">19 января 2019, суббота</h2>
</div>
<div class="panel-body" style="overflow:auto">
<table id="mobile-friendly" class="table table-bordered rasp">
<thead>
<tr>
<th style="width: 20px;" class="text-center">Номер урока</th>
<th class="text-center" style="width: 110px;">Время</th>
<th style="width: 350px;" class="text-center">Название предмета</th>
<th class="text-center">Кабинет</th>
<th class="text-center">Преподаватель</th>
</tr>
</thead>
<tbody>
<tr class="bordergrey"><td data-title="Номер урока" class="text-center" rowspan="1">1</td><td data-title="Время" class="text-center">08:00 - 08:45</td>
<td data-title="Название предмета">Интеллектуальные системы и технологии </td>
<td data-title="Кабинет" class="text-center">У-29</td>
<td data-title="Преподаватель" class="text-center">Кокшаров Сергей Владимирович</td>
</tr>
<tr class="borderwhite"><td data-title="Номер урока" class="text-center" rowspan="1">2</td><td data-title="Время" class="text-center">08:50 - 09:35</td>
<td data-title="Название предмета">Интеллектуальные системы и технологии </td>
<td data-title="Кабинет" class="text-center">У-29</td>
<td data-title="Преподаватель" class="text-center">Кокшаров Сергей Владимирович</td>
</tr>
<tr class="bordergrey"><td data-title="Номер урока" class="text-center" rowspan="1">3</td><td data-title="Время" class="text-center">09:45 - 10:30</td>
<td data-title="Название предмета">Безопасность и управление доступом </td>
<td data-title="Кабинет" class="text-center">У-310</td>
<td data-title="Преподаватель" class="text-center">Желонкина Марина Валерьевна</td>
</tr>
<tr class="borderwhite"><td data-title="Номер урока" class="text-center" rowspan="1">4</td><td data-title="Время" class="text-center">10:35 - 11:20</td>
<td data-title="Название предмета">Безопасность и управление доступом </td>
<td data-title="Кабинет" class="text-center">У-310</td>
<td data-title="Преподаватель" class="text-center">Желонкина Марина Валерьевна</td>
</tr>
<tr class="bordergrey"><td data-title="Номер урока" class="text-center" rowspan="1">5</td><td data-title="Время" class="text-center">11:50 - 12:35</td>
<td data-title="Название предмета">Безопасность и управление доступом </td>
<td data-title="Кабинет" class="text-center">У-310</td>
<td data-title="Преподаватель" class="text-center">Желонкина Марина Валерьевна</td>
</tr>
<tr class="borderwhite"><td data-title="Номер урока" class="text-center" rowspan="1">6</td><td data-title="Время" class="text-center">12:40 - 13:25</td>
<td data-title="Название предмета">Безопасность и управление доступом </td>
<td data-title="Кабинет" class="text-center">У-310</td>
<td data-title="Преподаватель" class="text-center">Желонкина Марина Валерьевна</td>
</tr> <tbody>
</table>
</div>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}