import Foundation
let pattern = #"(?:\[(?=[^][]*])(\w+)|\G(?!^))\h+(\w+)="([^"]+)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[specs product="test" category="body"]
[pricelist keyword="216"]
[specs product="test2" category="network"]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)