$re = '/(?:(?!^)\G|{msg)\s+\K(?:\w+|\[[^][]*])(?=[^}]*})/';
$str = 'text {msg ru key} text text {msg key [m=1,p=1]} text {msg ru key
[m=la la|p=1]} text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);