#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:[a-z]:)?[\/\\]{0,2}(?:[.\/\\ ](?![.\/\\\n])|[^<>:"|?*.\/\\ \n])+$"
Local $sString = "C://test" & @CRLF & _
"C://te?st.html" & @CRLF & _
"C:/test" & @CRLF & _
"C://test.html" & @CRLF & _
"C://test/hello.html" & @CRLF & _
"C:/test/hello.html" & @CRLF & _
"//test" & @CRLF & _
"/test" & @CRLF & _
"//test.html" & @CRLF & _
"//10.1.1.107" & @CRLF & _
"//10.1.1.107/test.html" & @CRLF & _
"//10.1.1.107/te st/hello.html" & @CRLF & _
"//10.1.1.107/test/hello" & @CRLF & _
"//test/hello.txt" & @CRLF & _
"/test/html" & @CRLF & _
"/tes?t/html" & @CRLF & _
"/test.html" & @CRLF & _
"test.html" & @CRLF & _
"//" & @CRLF & _
"/" & @CRLF & _
"\\\\" & @CRLF & _
"\\" & @CRLF & _
"/t!esrtr" & @CRLF & _
"C:/hel**o" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")