$re = '/^(.*)-.*$/m';
$str = 'branch:resource-fix-c95e12f';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;