using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^proj[a-zA-Z0-9]*_[a-zA-Z]+(?:_[0-9]+)?\.[a-z]+\.[a-z]+$";
string input = @"proj_asdasd_000.gz.xml
proj_asdasd.gz.xml";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}