# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^rgba?\((?:(?:(?:[0-9]{1,3} ){2}[0-9]{1,3}|(?:[0-9]{1,3}% ){2}[0-9]{1,3}%)(?: \/ (?:[0-9]{1,3}%|1|0|0?\.[0-9]+))?|(?:(?:[0-9]{1,3}, ){2}[0-9]{1,3}|(?:[0-9]{1,3}%, ){2}[0-9]{1,3}%)(?:, (?:[0-9]{1,3}%|1|0|0?\.[0-9]+))?)\)$"
test_str = ("// invalid\n"
"rgb()\n"
"rgba()\n"
"rgb(123)\n"
"rgb(11 22 )\n"
"rgb(11 22 2 / 03)\n"
"rgb(11 22 2 / 10)\n"
"rgb(1 2 3 / 0.34%)\n"
"rgb(11% 22 33)\n"
"rgb(111 222% 333)\n"
"rgb(1 22 333 )\n"
"rgb(1 2 3, 1)\n"
"rgb(1 2, 3 / 1)\n"
"// valid\n"
"rgb(111 22 333)\n"
"rgb(1 2 3)\n"
"rgb(11 22 33)\n"
"rgb(111 222 333)\n"
"rgb(1 22 333)\n"
"rgb(1 2 3 / 1)\n"
"rgb(11 22 2 / 0)\n"
"rgb(1 2 3 / 0.34)\n"
"rgb(1 2 3 / .34)\n"
"rgb(1 2 3 / 0.34)\n"
"rgb(1 2 3 / 1%)\n"
"rgb(1 2 3 / 10%)\n"
"rgb(1 2 3 / 100%)\n"
"rgb(11 22 2 / 0%)\n"
"rgb(1 2 3 / 34%)\n"
"rgb(1 2 3 / 4%)\n"
"rgb(111 22 333)\n"
"rgb(1% 2% 3%)\n"
"rgb(11% 22% 2% / 0)\n"
"rgb(12%, 0%, 100%)\n"
"rgb(111, 22, 333)\n"
"rgb(1, 2, 3)\n"
"rgb(1, 2, 3, 1)\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.