$re = '/([0-9A-Fa-f]{2}[:]){5}([0-9A-Fa-f]{2})/mu';
$str = 'Devices:\\n\\thci1\\t00:50:B6:80:4D:5D\\n\\thci0\\t00:15:83:15:A2:CB\\n';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);