#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b\d[\d\- ]*[A-Z]?\b"
Local $sString = "Via Treviso Mare 2 => need to detect 2" & @CRLF & _
"8C via Sergio Leone => need to detect 8C" & @CRLF & _
"Strada Provinciale 22 C => need to detect 22 C" & @CRLF & _
"19-20 Frazione Santa Maria => need to detect 19-20" & @CRLF & _
"9 - 11 via Giare => need to detect 9 - 11" & @CRLF & _
"Via Cesare Taiti 18-B => need to detect 18-B"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")