re = /\b\d[\d\- ]*[A-Z]?\b/
str = 'Via Treviso Mare 2 => need to detect 2
8C via Sergio Leone => need to detect 8C
Strada Provinciale 22 C => need to detect 22 C
19-20 Frazione Santa Maria => need to detect 19-20
9 - 11 via Giare => need to detect 9 - 11
Via Cesare Taiti 18-B => need to detect 18-B'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end