$re = '/{start}([\S\s]*?){end}/m';
$str = 'Please get the data between {start}
and the
{end} tag';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);