using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(int|string|float|void)\s[A-Za-z]+[(](([)]|(int|string|float)\s[A-Za-z]+|[,]\s(int|string|float)\s[A-Za-z]+)*[)])";
string input = @"int hola()
int hola(int abcd)
int hola(int abcd, int j)
int hola(int abcd, int j, int j)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}