$re = '/(int|string|float|void)\s[A-Za-z]+[(](([)]|(int|string|float)\s[A-Za-z]+|[,]\s(int|string|float)\s[A-Za-z]+)*[)])/m';
$str = 'int hola()
int hola(int abcd)
int hola(int abcd, int j)
int hola(int abcd, int j, int j)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);