re = /(int|string|float|void)\s[A-Za-z]+[(](([)]|(int|string|float)\s[A-Za-z]+|[,]\s(int|string|float)\s[A-Za-z]+)*[)])/m
str = 'int hola()
int hola(int abcd)
int hola(int abcd, int j)
int hola(int abcd, int j, int j)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end