use strict;
my $str = '={Proofs that yield nothing but their validity or all languages in NP have zero-knowledge proof systems},\\n
author={Goldreich, Oded and Micali, Silvio and Wigderson, Avi},\\n
journal={Journal of the ACM (JACM)},\\n
volume={38},\\n
number={3},\\n
pages={690--728},\\n
year={1991},\\n
publisher={ACM New York, NY, USA}\\n}';
my $regex = qr/.*?={([^{}]*)}.*/sp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";