// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[([\da-f]+)\]").unwrap();
let string = "[a1204f778edb7b4b]
[askjhd_zxcvjer4v]
[69e2176e8a5dcf8b]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}