package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)NSLocalizedString\((.*)\s*,\s*(.*)\)`)
var str = `// With text and comment
NSLocalizedString(@"Example Text", @"Example Comment");
// With text and no comment
NSLocalizedString(@"Example, text", nil)
// With text and comment with paranthesis
NSLocalizedString(@"Example text", @"Example (with paranthesis) comment")
// With property and no comment
NSLocalizedString(test, nil)
// With property and comment
NSLocalizedString(test, @"Example comment")
// Inline
NSLocalizedString(@"Error", nil) NSLocalizedString(@"Change settings", @"Option to change HTTP Post settings") NSLocalizedString(@"Cancel", nil)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}