import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "NSLocalizedString\\((.*)\\s*,\\s*(.*)\\)";
final String string = "// With text and comment\n"
+ "NSLocalizedString(@\"Example Text\", @\"Example Comment\");\n\n"
+ "// With text and no comment\n"
+ "NSLocalizedString(@\"Example, text\", nil) \n\n"
+ "// With text and comment with paranthesis\n"
+ "NSLocalizedString(@\"Example text\", @\"Example (with paranthesis) comment\") \n\n"
+ "// With property and no comment\n"
+ "NSLocalizedString(test, nil)\n\n"
+ "// With property and comment\n"
+ "NSLocalizedString(test, @\"Example comment\")\n\n"
+ "// Inline\n"
+ "NSLocalizedString(@\"Error\", nil) NSLocalizedString(@\"Change settings\", @\"Option to change HTTP Post settings\") NSLocalizedString(@\"Cancel\", nil)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}