#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:http|ftp)s?://)?[\w:@.-]+\.[\w-]+(?::\d+)?\??[\w.\~:/?#\[\]@!$&'()*+,;=.%-]*$"
Local $sString = "http://goooooooooooooooooglllllllllllllllllllllllllllllllllllllle.com:12?queryyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy" & @CRLF & _
"http://goooooooooooooooooglllllllllllllllllllllllllllllllllllllle.com:12?queryyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy yy"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")