Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
-\n([^(]+)(\(\d\))[|]([^-]+)
/
gm
Input 1
1
New
-------------------------------------------------------------------------------- PHYS 11A GEN PHYS-MECHANICS (4)|NOT ARTICULATED -------------------------------------------------------------------------------- PHYS 11B GEN PHYS-HEAT,LIGHT,SOUND (4)|NOT ARTICULATED -------------------------------------------------------------------------------- PHYS 11C GEN PHYS-ELECT,MAG,MOD (4)|NOT ARTICULATED -------------------------------------------------------------------------------- MATH 30 CALCULUS I (4)|MATH 180 Single Variable (4) | Calculus I -------------------------------------------------------------------------------- MATH 31 CALCULUS II (4)|MATH 185 Single Variable (4) | Calculus II -------------------------------------------------------------------------------- MATH 32 CALCULUS III (4)|MATH 280 Intermediate Calculus (4) -------------------------------------------------------------------------------- MATH 45 DIFFERNTL EQUATN SCI+ENGR (3)|MATH 295 Differential Equations (3) |