use strict;
my $str = '10.1.1.0/27';
my $regex = qr/\/.*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";