import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:(?:0?[13578]|1[02])(\\/)31)\\1|(?:(?:0?[1,3-9]|1[0-2])(\\/)(?:29|30)\\2))(?:(?:19|[2-9]\\d)\\d{2})$|^(?:0?2(\\/)29\\3(?:(?:(?:19|20)(?:0[048]|[2468][048]|[13579][26]))))$|^(?:(?:0?[1-9])|(?:1[0-2]))(\\/)(?:0?[1-9]|1\\d|2[0-8])\\4(?:(?:19|[0-9]\\d)?\\d{2})$";
final String string = "1/1/2019\n"
+ "2/29/2020\n"
+ "1/31/00\n"
+ "2/29/2000\n"
+ "3/31/2019\n"
+ "2/29/2020\n"
+ "7/23/1999\n"
+ "7/31/1999\n"
+ "7/28/1999\n"
+ "7/21/1999\n"
+ "7/5/1964\n"
+ "7/21/2000\n"
+ "2/29/1900\n"
+ "6/5/1999\n"
+ "5/5/1999\n"
+ "4/4/1999\n"
+ "3/3/1999\n"
+ "2/2/1999\n"
+ "2/29/1996\n"
+ "2/29/2000\n"
+ "1/1/1954\n"
+ "1/1/1985\n"
+ "3/31/2019\n"
+ "1/29/2010\n"
+ "10/21/1967";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}