package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Ulcerative colitis patient, biopsy taken from the(\s?\w*\s?)colon,(\s?\w*\s?)macroscopic inflammation vissible`)
var str = `Ulcerative colitis patient, biopsy taken from the descending colon, macroscopic inflammation vissible
Ulcerative colitis patient, biopsy taken from the descending colon, no macroscopic inflammation vissible
Ulcerative colitis patient, biopsy taken from the colon, macroscopic inflammation vissible
Ulcerative colitis patient, biopsy taken from the colon, no macroscopic inflammation vissible`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}