import Foundation
let pattern = #"A1 (.*), A2 (.*), A3 (.*), A4 (.*), A5 (.*), A6 (.*), X (.*), Y (.*), Z (.*), A (.*), B (.*), C (.*), S (.*), T (.*), BN (.*), TN (.*)(?:(, TOP (.*)])?)\}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{TRAME: A1 87.75179, A2 -6.815482, A3 8.777070, A4 -0.115212, A5 87.54638, A6 -1.914512, X 97.43790, Y -2582.634, Z 578.5095, A -89.67130, B -4.879062E-01, C 0.130585, S 2, T 42, BN 0, TN 2}
{TRAME: A1 87.75179, A2 -6.815482, A3 8.777070, A4 -0.115212, A5 87.54638, A6 -1.914512, X 97.43790, Y -2582.634, Z 578.5095, A -89.67130, B -4.879062E-01, C 0.130585, S 2, T 42, BN 0, TN 2, TOP 32}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)