using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^a-zA-Z0-9\s]+";
string input = @"{“23 882 91 317”, “55 672 871 437”, “230 12 435 907”, “320 32 855 107”}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}