const regex = /[^a-zA-Z0-9\s]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-zA-Z0-9\\s]+', 'gm')
const str = `{“23 882 91 317”, “55 672 871 437”, “230 12 435 907”, “320 32 855 107”}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}