import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[.+](?=[^\\s@]*@gmail\\.com)";
final String string = "john.brian@gmail.com\n"
+ "henix..mail+@gmail.com\n"
+ "sar+ah+.black+.+@gmail.com";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}