re = /[.+](?=[^\s@]*@gmail\.com)/m
str = 'john.brian@gmail.com
henix..mail+@gmail.com
sar+ah+.black+.+@gmail.com'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result