import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\d{9}$).*$";
final String string = "123456789\n"
+ "12345678\n"
+ "1234567890\n"
+ "12a345\n"
+ "123abc789\n"
+ "987654321\n"
+ "111111111\n"
+ "222222222\n"
+ "abc\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}