$re = '/^(?!\d{9}$).*$/m';
$str = '123456789
12345678
1234567890
12a345
123abc789
987654321
111111111
222222222
abc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);