$re = '/\s\S*/m';
$str = 'I am too high for our ladder. I am two hi for our ladder. I am to high four hour ladder';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);