#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[A-Z][A-Z0-9]?\b"
Local $sString = "Height of Building code J 9.5m" & @CRLF & _
"Height of Building code T1 26.0m" & @CRLF & _
"Height of Buildings O=16 Metres" & @CRLF & _
"Maximum Building Height (RL m) 50m"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")