import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[A-Z][A-Z0-9]?\\b";
final String string = "Height of Building code J 9.5m\n"
+ "Height of Building code T1 26.0m\n"
+ "Height of Buildings O=16 Metres\n"
+ "Maximum Building Height (RL m) 50m";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}