$re = '/\b[A-Z][A-Z0-9]?\b/m';
$str = 'Height of Building code J 9.5m
Height of Building code T1 26.0m
Height of Buildings O=16 Metres
Maximum Building Height (RL m) 50m';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);