import re
regex = re.compile(r"\b[A-Z][A-Z0-9]?\b", flags=re.MULTILINE)
test_str = ("Height of Building code J 9.5m\n"
"Height of Building code T1 26.0m\n"
"Height of Buildings O=16 Metres\n"
"Maximum Building Height (RL m) 50m")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")