using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([[:alpha:]|\s]+\.)";
string input = @"This is my string. This string is a sample. This is a problem.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}