package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([[:alpha:]|\s]+\.)`)
var str = `This is my string. This string is a sample. This is a problem.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}