package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:BE)?\s*?[0-1]?((\d[. ]*){9})$`)
var str = `BE 0123.321.123
BE0123.321.123
BE0123 321 123
1123.321.123
123.321.123
123321123
BE1233221221
BE123322122
BE 0123..... 321 122
BE 01 23 32 11 23
aae233432233 23343`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}