$re = '/\w*ViewModel|(\w{2,}Model)\b/m';
$str = 'MyModel // - do match
MyViewModel // - do not match
This is a Model and this is another model
This is MyModelTrain testModel';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);