# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(\d+)(\s?)(f{1,2})(?:(\.)\B|\b(?!\.))"
test_str = ("00f aaa +\n"
"00f. aaa +\n"
"00ff aaa +\n"
"00ff. aaa +\n"
"00 f aaa + \n"
"00 f. aaa +\n"
"00 ff aaa +\n"
"00 ff. aaa +\n"
"+ aaa 00f aaa +\n"
"+ aaa 00f. aaa +\n"
"+ aaa 00ff aaa +\n"
"+ aaa 00ff. aaa +\n"
"+ aaa 00 f aaa + \n"
"+ aaa 00 f. aaa +\n"
"+ aaa 00 ff aaa +\n"
"+ aaa 00 ff. aaa +\n"
"+ aaa 00f\n"
"+ aaa 00f.\n"
"+ aaa 00ff\n"
"+ aaa 00ff.\n"
"+ aaa 00 f \n"
"+ aaa 00 f.\n"
"+ aaa 00 ff\n"
"+ aaa 00 ff.\n\n"
"00 faaa -\n"
"00 f.aaa -\n"
"00 ffaaa -\n"
"00 ff.aaa -\n"
"00af aaa - \n"
"00af. aaa -\n"
"00aff aaa -\n"
"00aff. aaa -\n"
"- aaa 00 faaa -\n"
"- aaa 00 f.aaa -\n"
"- aaa 00 ffaaa -\n"
"- aaa 00 ff.aaa -\n"
"- aaa 00af aaa - \n"
"- aaa 00af. aaa -\n"
"- aaa 00aff aaa -\n"
"- aaa 00aff. aaa -\n"
"- aaa00f\n"
"- aaa00f.\n"
"- aaa00ff\n"
"- aaa00ff.\n"
"- aaa 00af \n"
"- aaa 00af.\n"
"- aaa 00aff\n"
"- aaa 00aff.\n\n"
"00faaa -\n"
"00f.aaa -\n"
"00ffaaa -\n"
"00ff.aaa -\n"
"00af aaa - \n"
"00af. aaa -\n"
"00aff aaa -\n"
"00aff. aaa -\n"
"- aaa00 faaa -\n"
"- aaa00 f.aaa -\n"
"- aaa00 ffaaa -\n"
"- aaa00 ff.aaa -\n"
"- aaa00af aaa - \n"
"- aaa00af. aaa -\n"
"- aaa00aff aaa -\n"
"- aaa00aff. aaa -\n"
"- aaa00af \n"
"- aaa00af.\n"
"- aaa00aff\n"
"- aaa00aff.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.