package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?x)
(^\s*"(?:match|begin|end)"\s*:\s*)
(")
(?:
(?=\2)
|
(?:
(?<esc>(?:\\\\(?:\\\\|[nsrbwSNRW"\$\^\*\)\(\[\]\{\}]?)))
|
(?<ctrl>[\(\)\[\]\{\}]+|[^"\(\)\[\]\{\}\\]+)
|
(?<def>[^"\\])
)+
)
(\2)`)
var str = `{
"repository": {
"meta": {
"patterns": [
{
"begin": "\\$\\(\\(",
"end": "\\)\\)",
// "name": "meta.arithmetic-expansion.zsh",
"name": "storage.type.zsh",
},
{
"begin": "\\$\\(",
"end": "\\)",
// "name": "meta.command-substitution.zsh",
"name": "storage.type.zsh",
},
{
"begin": "\\$\\{",
"end": "\\}",
// "name": "meta.parameter-expansion.zsh",
"name": "storage.type.zsh",
}
]
}
}
}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}